Having problem to add an image to 23-samii_adib, the ID is not found,

+2 votes
85 views
in Genealogy Help by Ali Samii G2G1 (1.6k points)

If you mean the profile page, it should rather look like samii_adib-23 (but that one does not exist, so maybe you mean Samii-23 )?

smiley Wikitree Profile ID# are read from left to right, so the number assigned to the surname is on the right of the surname, such as Jones-12 and Williams-570 and Smith-15834 

Michael and Susan, you guys are misinformed. The Arabic language is written from right to left. So when displayed, it appears that the ID is on the left side of the surname. This is correct. but under the hood (and mostly invisible to all of us) its still stored in the database on the right side (although technically that's probably not the correct way to describe it)

I too was surprised to see that WikiTree had created the profiles with the ID number appearing the left instead of the right, but it makes sense for the language: https://www.wikitree.com/wiki/23-ادیب سمیعی

Even more interesting when copying the unicode URL, the ID number is magically moved to the right side again when its url encoded:
https://www.wikitree.com/wiki/%D8%A7%D8%AF%DB%8C%D8%A8_%D8%B3%D9%85%DB%8C%D8%B9%DB%8C-23

In his question, Ali has written the surname ادیب سمیعی in English for us to read, samii_adib, but that's not how its stored in the database. So, strictly speaking, the profile "23-ادیب سمیعی" exists, but neither "23-samii_adib" or "samii_adib-23" exist.

I'm not able to offer any suggestions to Ali's actual question. I suspect that will have to be a tech/admin question.

But the profile does have one image attached to it already.

Well, that is interesting. Because if you check the generated link, you get the described error. Somehow a part of the name is not incorporated.

@Ali, if you tag your question with the wikitech tag you might attract attention from the real tech team.

For the tech people: this is the profile ID:


'Id': 13511479, 'Name': 'ادیب سمیعی-23'

It seems as if there is a space in the profile name which might cause the trouble (with Latin these get replaced with and underscore as far as I know).

Michael, the error in the generated link in my post is because of the space in the name. I didn't take care to quote it properly.

edit: nevermind... you already noted that.

3 Answers

+1 vote

Have you gone to that profile and added an image to it?  That should add an image to that profile.  I suspect the problem is the way that ID is formatted could be the problem. 

Help for Photos FAQ

by Linda Peterson G2G6 Pilot (533k points)
+1 vote
Ali, can you be more specific as to what exactly the problem is? What steps have you tried? What is the error message/response you are getting?

The profile you mentioned already has an image attached to it. Did you have trouble uploading that one?

Most problems with uploading images are usually due to their size. Jpeg images, for example, are much larger (total pixels) than they seem to be based on their file size (compressed).

It could be possible that there might be a problem if the image filename is in Arabic (but I wouldn't think so).
by Dennis Wheeler G2G6 Pilot (537k points)
0 votes

I tried searching using the family name Samii Adib as well as Adib Samii. I could not find the profile that you are looking for.

I searched using the family name ادیب سمیعی and I did find a profile for هادی خان ادیب سمیعی . His profile is listed as 23-سمیعی_ادیب and the photo is there.

by A. Creighton G2G6 Pilot (648k points)

Related questions

+2 votes
1 answer
+1 vote
1 answer
+2 votes
1 answer
+2 votes
1 answer
72 views asked Jul 11, 2017 in Genealogy Help by anonymous
+1 vote
1 answer
46 views asked Aug 10, 2020 in Genealogy Help by Ali Samii G2G1 (1.6k points)

WikiTree  ~  About  ~  Help Help  ~  Search Person Search  ~  Surname:

disclaimer - terms - copyright

...