Is anyone else having trouble with WikiTree X?

+4 votes
47 views

This morning as I've tried to use WikiTree X, I'm getting nuthin'.

I've tried using it on both Find-a-Grave and FamilySearch, and it won't open up when I click it.

Is anyone else having similar problems?

asked in WikiTree Tech by Julie Ricketts G2G6 Pilot (266k points)

1 Answer

+5 votes
Update: If your'e having issues, try clearing your cache & restarting your browser. This fixed it. :-)
answered by Julie Ricketts G2G6 Pilot (266k points)
For me, it has often required restarting the browser if I wanted to use WIkiTree X a second time.  I'm not sure that's always the case, but often it refused to work more than once.

Related questions

+1 vote
0 answers
+5 votes
1 answer
87 views asked Mar 20, 2017 in WikiTree Tech by Peggy McMath G2G6 Mach 1 (18.2k points)
+5 votes
2 answers
82 views asked Jun 19, 2017 in WikiTree Tech by Mirosław Płocieniak G2G Crew (310 points)
+8 votes
2 answers
73 views asked Nov 5, 2017 in WikiTree Help by Stephanie Stults G2G6 Mach 3 (35.5k points)
+8 votes
0 answers
97 views asked Aug 13, 2017 in WikiTree Tech by William Foster G2G6 Mach 6 (68.2k points)
+6 votes
1 answer
68 views asked Jul 26, 2017 in WikiTree Tech by Lance Martin G2G6 Mach 7 (72.7k points)
+9 votes
1 answer
88 views asked Apr 24, 2018 in The Tree House by Beulah Cramer G2G6 Pilot (162k points)
+2 votes
0 answers
+3 votes
1 answer

WikiTree  ~  About  ~  Help Help  ~  Search Person Search  ~  Surname:

disclaimer - terms - copyright

...