Is anyone else having issues using RootsSearch?

+5 votes
129 views
When I try to use RootsSearch from WikiTree nothing happens. It won’t open a new tab and auto fill the search but leaves me on the login page. Is this a known issue?
in WikiTree Tech by Deborah Talbot G2G6 Mach 5 (57.4k points)
Thank you for asking this question, Deborah. Haven't experienced that problem, but did a check using my grandfathers profile and discovered that his WWI Draft record has a different name than we knew him by.  He had a first name, unknown to us, and was going by his middle name.

2 Answers

+3 votes
Yours is the third posting I've seen over a several day span so I suspect you aren't alone, Deborah!
by Dorothy Coakley G2G6 Pilot (174k points)
+1 vote
This should be fixed now.
by Jamie Nelson G2G6 Pilot (360k points)
It is still stuck for me
Try clearing your cache and cookies.
Off for me at 2:30 pm EST  New York
Did either of you change your passwords recently?
No. It was working fine this morning.  It was also working fine for me when other people were off line over the past two or three days.  Queer!
Same here, I only use it rarely but it is still not working.
Still out for me on Sat. 10:30 am New York.
I’ve had the same problem for several days. It’s really cramping my style.

Related questions

+5 votes
1 answer
139 views asked Apr 26, 2018 in The Tree House by Kaylee Robinson G2G6 Mach 2 (24.6k points)
+6 votes
2 answers
+11 votes
10 answers
+5 votes
2 answers
+5 votes
2 answers
178 views asked May 27, 2018 in WikiTree Tech by Kaylee Robinson G2G6 Mach 2 (24.6k points)
+22 votes
9 answers
+8 votes
1 answer
219 views asked Aug 22, 2017 in WikiTree Tech by Jon Czarowitz G2G6 Mach 4 (40.0k points)

WikiTree  ~  About  ~  Help Help  ~  Search Person Search  ~  Surname:

disclaimer - terms - copyright

...