Anyone else having issues with FamilySearch Matches?

+4 votes
194 views
Hello, lovelies!

It could just be me, but I've been having an issue with FamilySearch Matches where it won't allow me to log in to FS—and if it does, it stays on the loading page without doing anything. I've been trying to use FSM for over ten hours, leaving it and coming back, reloading and re-signing in, and it still doesn't work. Obviously it could just be an issue on my end, but I was curious as to whether anyone else is finding the same problem?
in WikiTree Tech by Amelia Utting G2G6 Pilot (191k points)

4 Answers

+2 votes
Hmmm ... working fine here ... ??
by Bob Jewett G2G Astronaut (1.2m points)
+4 votes
I haven't seen that today. Have you cleared your cache and restarted your browser?
by Doug McCallum G2G6 Pilot (449k points)
+5 votes
No problems logging in, but have been having issues trying to cut and paste citations.  Switched from Chrome to Edge and that solved the problem. Have you tried switching browsers?
by Fred Adamson G2G6 Pilot (140k points)
+4 votes
When logging in, be sure to tick the box that says "stay logged in for two weeks".

That sets a cookie on your device that will keep you logged in every time you revisit that site. Otherwise, the default session will expire after a short time, causing you to have to log in again -- as you are experiencing.
by Dennis Wheeler G2G6 Pilot (539k points)

Related questions

+8 votes
5 answers
+1 vote
2 answers
0 votes
1 answer
99 views asked Dec 14, 2021 in The Tree House by Jeff Michaelsen G2G6 Mach 2 (20.5k points)
+3 votes
0 answers
+1 vote
1 answer
121 views asked Jun 12, 2017 in WikiTree Tech by Thom Anderson G2G6 Mach 6 (63.7k points)
+17 votes
3 answers
+5 votes
1 answer
+5 votes
1 answer

WikiTree  ~  About  ~  Help Help  ~  Search Person Search  ~  Surname:

disclaimer - terms - copyright

...