BUG: Double colon no longer generating blank line [closed]

+3 votes
175 views

I have spent an enormous amount of time cleaning up the biographies of over 600 individuals from my upload.  I thought I understood the editing to create a paragraph break.  It worked fine yesterday, but today, none of my double-line breaks are working with indentions.  Why did it work yesterday, but not today?  For instance, with Lewis-12396, there are double-line breaks in the Birth section and the Marriage section of the Biography, but it is no longer creating a paragraph break like it did the day I first edited it. 

WikiTree profile: John Lewis
closed with the note: Resolved
in WikiTree Tech by L Adcox G2G1 (1.9k points)
closed by Keith Hathaway
L.,

FYI double blank lines do not show up when viewing the profile via an iphone.
L. Adcox,

Have you tried using the <br /> for carriage return? Or <br /><br /> for double return?

I want to clarify my problem.  I want to see a blank line between 2 lines of text.  How do I accomplish this?  The Wiki Editing Tips screen says that <br /> creates a single line break, and two line breaks create a new paragraph.  I want to create a new paragraph, meaning a blank line between 2 lines of text.  This does not appear to work.  A few days ago, I could see the blank line, but today I cannot.  I am on a regular computer, the same as a few days ago. I am not on a iphone. 

 

Double colons on an empty line should now appear as a blank line, as it did before.

Note that technically, on the back end, what you're doing by starting a line with two colons is creating a nested definition list. In the old style, if a nested definition list was empty it still took up space. In the new design, empty lists did not take up space. Now they do again.
Thanks for fixing the problem.  I no longer need to update my 600+ profiles with double-colons (thank goodness).  My profiles now appear good again.
Chris,

Thanks.

The reason i started using double colons for blank indented lines is because single wouldn't work.

2 Answers

+2 votes
 
Best answer

Okay, I see the problem; you're making use of ":" to indent each line of text. Here's a copy/paste of a section:

:  John and Melissa are 1st cousins; both born with surname LEWIS
:  Shared grandparents are: Joseph Lewis and Nancy Faulkner
 
:  2nd MARRIAGE:
:  1896: marriage of John G Lewis to Sarah R ___ (per 1900 census - married 4 years)
 
:  3rd MARRIAGE:
:  1904: marriage to John G Lewis to Susan ___ (per 1910 census - married 6 years)
 
I bet you're expecting a blank line before "2nd MARRIAGE:" and before "3rd MARRIAGE:"
 
To achieve that you need to do this:
:  John and Melissa are 1st cousins; both born with surname LEWIS
:  Shared grandparents are: Joseph Lewis and Nancy Faulkner
::
:  2nd MARRIAGE:
:  1896: marriage of John G Lewis to Sarah R ___ (per 1900 census - married 4 years)
::
:  3rd MARRIAGE:
:  1904: marriage to John G Lewis to Susan ___ (per 1910 census - married 6 years)
 

This was true before the redesign of the interface. At least, in my experience, that the use of a "::" between indented lines that start with ":" has always been required to insert a blank line. 

When NOT using ":" you simply add a blank line with your RETURN or ENTER key.

 

by Jillaine Smith G2G6 Pilot (757k points)
selected by Debra Allison

Yes, absolutely, I am expecting a blank line before "2nd MARRIAGE:" and before "3rd MARRIAGE:"  I have inserted the "::" just like your example, but that does not work.   What is the new method since the redesign of the interface?

AH, THAT'S the Bug. Okay. You're right. the double ":" stopped working. Don't know why, but let's see what the big guns say.

I've modified the title, changed the category to Wiki Tech, and hopefully we'll get some tech attention soon.

(I have a TON of profiles that make use of the double-colon, so this affects me as well.)
I also saw and removed some random HTML code you had in there that was incomplete. But it didn't solve the problem.
Hi Jillaine and L.,

We should be able to fix this. Hold tight ...
OK, this should now be fixed. Two colons now behaves how it used to behave, i.e. with a blank line.
That fixed my problem.  Apparently it is NOT necessary to insert a "::" between indented lines that start with ":" to generate a blank line.   All of my blank lines between indentions are now visible again.  Thanks
+1 vote
L., I'm now on a laptop. It looks like it's not an extra blank line, but that the line spacing has been increased from single spacing to something like 1.5 line spacing.  For different reasons, I dislike this new spacing. It requires far more scrolling.
by Jillaine Smith G2G6 Pilot (757k points)

Related questions

+12 votes
1 answer
+12 votes
1 answer
+29 votes
7 answers
+14 votes
0 answers
+2 votes
3 answers
69 views asked Jul 22, 2014 in WikiTree Tech by Maryann Hurt G2G6 Mach 8 (84.3k points)
+11 votes
1 answer

WikiTree  ~  About  ~  Help Help  ~  Search Person Search  ~  Surname:

disclaimer - terms - copyright

...